E-Verify is experiencing technical issues

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 13:53 EDT

Investigating


Impact: E-Verify is currently experiencing technical issues which is causing a delay with onboarding applicants.
System: Talent Platform
Description: E-Verify is aware of this and is working to resolve the problem.
Posted Mar 13, 2026 - 10:37 EDT
This incident affected: Bullhorn Talent Platform (Talent Platform - US Prod, Talent Platform - UK Prod, Talent Platform - CA Prod, Talent Platform - US Staging, Talent Platform - UK Staging, Talent Platform - AU Staging).