Delayed events on SL41
Incident Report for Bullhorn
Resolved
This incident has been resolved.
Posted 6 months ago. Dec 29, 2018 - 23:15 EST
Investigating
We are currently investigating an issue whereby events are delayed for SL41
Posted 6 months ago. Dec 29, 2018 - 22:56 EST
This incident affected: CRM (CLS41).