Performance Issues - Invenias Service Interruption

Incident Report for Bullhorn

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2025 - 11:00 EDT

Investigating


Impact: Some users may experience latency and/or errors when logging in.
System: Invenias by Bullhorn
RING: [GA]
Data Centres: West Europe
Service: [Desktop and Web]
Description: The Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Mar 31, 2025 - 10:07 EDT
This incident affects: Additional Bullhorn Solutions (Invenias by Bullhorn).