Scheduled Maintenance - Bullhorn Back Office

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 18:03 EDT

Investigating


Impact: Emergency Maintenance Schedule For 5:30 PM EST. During this maintenance period, clients could observe intermittent system latency and/or in-app errors.
System: Bullhorn Back Office
Cluster(s): GRR & EMEA
Description: Bullhorn Technical Services will be performing scheduled system maintenance during the above time frame. Additional updates will be posted here if necessary.
Posted Mar 12, 2026 - 15:01 EDT
This incident affected: Bullhorn Back Office (BBO GRR, BBO UK).