Scheduled Maintenance - Bullhorn ATS/CRM
Incident Report for Bullhorn
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 11:56 EDT
Investigating
We are currently investigating this issue.
Posted Sep 16, 2020 - 15:00 EDT
This incident affected: Bullhorn ATS/CRM (CLS21, CLS22, CLS23, CLS70) and Sandbox (CLS29).