Bullhorn Talent Platform - Staging Performance

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Jun 28, 2026 - 21:18 EDT

Investigating


Impact: Some users may experience latency issues with syncing data from ATS to Talent Platform.
System: Bullhorn Talent Platform
Cluster(s): Staging US
Service: All / Data Integration
Description: The Bullhorn Technical Operations team is investigating an event processing backlog affecting our Staging environments. Users may experience significant delays with data syncing and record updates within Staging. Further updates will be posted here when available.
Posted Jun 28, 2026 - 19:44 EDT
This incident affected: Bullhorn Talent Platform (Talent Platform - US Staging).