Bullhorn Talent Platform - Dropbox Sign Maintenance

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 21:26 EDT

Monitoring


Impact: Dropbox Sign and Fax will be performing routine maintenance on October 1, 2025 starting at 5:00 PM (Pacific). You may not be able to access Dropbox Sign or Fax for a short period of time. For more information, please visit https://status.hellosign.com/
System: Bullhorn Talent Platform
Service: Dropbox Sign
Description: The Bullhorn Technical Operations team is monitoring this issue, further updates will be posted here when available.
Posted Oct 01, 2025 - 19:01 EDT
This incident affected: Bullhorn Talent Platform (Talent Platform - US Prod, Talent Platform - UK Prod, Talent Platform - CA Prod, Talent Platform - US Staging, Talent Platform - UK Staging).