Performance Issues - Talent Platform (formerly Onboarding Talent Edition)

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 16:08 EDT

Investigating

Impact: Some users may experience issues with conditional form logic in the Talent Platform application.
System: Bullhorn Talent Platform
Cluster(s): Prod US
Service: All
Description: The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Jun 24, 2026 - 12:06 EDT
This incident affected: Bullhorn Talent Platform (Talent Platform - US Prod).