Bullhorn ATS / CRM - Performance issues - SLs 40-45

Incident Report for Bullhorn

Resolved

This issue has been resolved and we are no longer seeing any latency or performance issues.
Posted Feb 20, 2026 - 12:18 EST

Monitoring

Latency has been addressed and we are currently monitoring behavior.
Posted Feb 20, 2026 - 11:01 EST

Investigating

Some users may experience latency and/or errors when logging in or using the Bullhorn application. The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Feb 20, 2026 - 10:44 EST
This incident affected: Bullhorn ATS/CRM (CLS40, CLS41, CLS42, CLS43, CLS44, CLS45).