Performance Issues - Connexys Fast Forward

Incident Report for Bullhorn

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2026 - 05:52 EDT

Investigating


Impact: Users may experience latency and/or errors when sending emails using the Connexys Fast Forward application.
System: Connexys Fast Forward
Service: All
Description: The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Sep 09, 2026 - 05:39 EDT
This incident affects: Bullhorn for Salesforce (Bullhorn FastForward).