Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 25 days ago. Jun 11, 2025 - 03:00 EDT
Scheduled
Impact: During this maintenance period, the Talent Platform will be unavailable. This includes access to Talent Platform through the direct website or via system integration. System: Bullhorn Talent Platform Cluster(s): Staging/ Non-Production Description: Bullhorn Technical Services will be performing scheduled system maintenance during the above time frame. Additional updates will be posted here if necessary.
Posted 26 days ago. Jun 09, 2025 - 10:01 EDT
This scheduled maintenance affected: Additional Bullhorn Solutions (Talent Platform).
Your Bullhorn ATS/CRM Cluster
To determine which cluster you are on, right click anywhere on the home page after sign in & click “View page source”. Scroll down to the bottom of this page and locate “swimLaneId” this is the cluster number that your company is on.