A Fix for this issue will be rolled out in due course, please reach out to support for further assistance or or to discuss any questions you may have.
Posted Oct 27, 2025 - 11:25 EDT
Update
A fix has been created and is anticipated to be released soon.
Posted Oct 06, 2025 - 11:34 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 01, 2025 - 11:01 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 29, 2025 - 03:41 EDT
Identified
The issue has been identified, and a solution to have the audit trail information prior to 28/9/2025 displaying again is being investigated
Posted Sep 29, 2025 - 03:40 EDT
Investigating
Impact: no historical data changes for applicants showing under Audit Trail tab before the dates of 28/9 (EDT) System: Bullhorn Talent Platform Cluster(s): US Prod Service: All Description: applicant data updates from before 28/9/2025 are not showing. If you need this information for specific applicants, please reach out to support.
Posted Sep 29, 2025 - 03:39 EDT
This incident affected: Bullhorn Talent Platform (Talent Platform - US Prod).