Bullhorn Talent Platform - Applicant Document Issues

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 11:27 EDT

Identified


Impact: Some applicants are unable to view documents when using the Talent Platform.
System: Bullhorn Talent Platform
Cluster(s): Production
Service: All
Description: We're aware of an intermittent issue with applicants being unable to view documents and tasks from the applicant portal. This is being investigated by the Bullhorn Technical Operations team, further updates will be posted here when available.
Posted Sep 05, 2025 - 10:37 EDT