Bullhorn ATS/CRM - Login

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 10:33 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2025 - 10:26 EDT

Investigating


Impact: Some users may experience errors when attempting to access https://app.bullhornstaffing.com
System: Bullhorn ATS/CRM
Cluster(s): All
Service: Login
Description: The Bullhorn Technical Operations team is investigating this issue, this issue relates to client's ISP. Please perform a DNS Cache flush on your device to resolve the issue.
Posted Apr 14, 2025 - 09:53 EDT
This incident affected: Bullhorn ATS/CRM (CLS20, CLS21, CLS22, CLS23).