Bullhorn ATS/CRM - Performance Issues

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Mar 22, 2025 - 10:54 EDT

Investigating


Impact: Some users may experience latency and/or errors when logging in or using the Bullhorn application.
System: Bullhorn ATS/CRM
Cluster(s): CLS30, CLS31, CLS32, CLS33, CLS34, CLS35
Service: All
Description: The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Mar 22, 2025 - 10:30 EDT
This incident affected: Bullhorn ATS/CRM (CLS30, CLS31, CLS32, CLS33, CLS34, CLS35).