Performance Issues - Bullhorn Talent Platform

Incident Report for Bullhorn

Resolved

This incident has now been resolved.
Posted Jan 14, 2026 - 16:57 EST

Investigating


Impact: Some users may experience intermittent latency and/or errors when document signing within the Bullhorn Talent Platform application.
System: Bullhorn Talent Platform
Cluster(s): Prod
Service: Document Signing
Description: The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Jan 13, 2026 - 19:29 EST
This incident affected: Bullhorn Talent Platform (Talent Platform - US Prod).