Email Delay - Bullhorn Talent Platform

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 10:28 EDT

Monitoring

Bullhorn Talent Platform is experiencing intermittent email sending delays or bounces due to external email provider spam controls. This is occurring more frequently with yahoo.com or outlook.com destinations. We expect this to continually improve over time as successful emails are making it through.
Posted Jun 18, 2025 - 14:56 EDT
This incident affected: Bullhorn Talent Platform (Talent Platform - US Prod).