Login Issues - Estaff365
Incident Report for Bullhorn
Resolved
This incident has been resolved.
Posted Jan 06, 2021 - 15:55 EST
Investigating

Impact: Some users may experience latency and/or errors when attempting to login or use the Estaff365 application.
System: Estaff365
Service: All
Description: The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Jan 06, 2021 - 13:00 EST
This incident affected: Additional Bullhorn Solutions (eStaff365).