Bullhorn ATS/CRM - SL31 Login - Resolved

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 12:37 EDT

Monitoring


Impact: Some users may have experienced latency and/or errors when logging into the Bullhorn application around 11:49 AM EST. This has since been resolved.
System: Bullhorn ATS/CRM
Cluster(s): CLS31
Service: Login
Description: The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Mar 12, 2026 - 12:17 EDT
This incident affected: Bullhorn ATS/CRM (CLS31).