Some users may experience latency and/or errors when logging in or using the Back Office application. Specifically, users may encounter errors when attempting to access uploaded documents or custom data exports.

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 12:32 EDT

Monitoring

A fix has been implemented and we are currently monitoring results.
Posted Jun 11, 2026 - 12:01 EDT

Identified

The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Jun 11, 2026 - 11:30 EDT
This incident affected: Bullhorn Back Office (BBO GRR, BBO UK).