Bullhorn Back Office - Email Delivery Issues

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 09:30 EST

Investigating


Impact: Some users may experience email delivery issues when using the Back Office application.
System: Bullhorn Back Office
Cluster(s): BBO SNG
Service: All
Description: The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Jan 13, 2026 - 19:26 EST
This incident affected: Bullhorn Back Office (BBO SNG).