Bullhorn Talent Platform - Performance Issues

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 09:29 EST

Investigating

Some customers may experience an error when attempting to make API calls with SSL certification. Our team is currently investigating the cause of this issue.
Posted Mar 05, 2025 - 09:06 EST
This incident affected: Additional Bullhorn Solutions (Talent Platform).