Bullhorn ATS/CRM - help.bullhorn.com is Down

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 06:22 EDT

Investigating


Impact: Users are unable to access help.bullhorn.com to get support or raise support tickets.
System: Bullhorn ATS/CRM
Service: Bullhorn Help Portal
Description: The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Jul 20, 2026 - 02:38 EDT