Performance Issues - Maxhire
Incident Report for Bullhorn
Resolved
This incident has been resolved.
Posted Aug 17, 2019 - 13:26 EDT
Investigating

Impact: Some users may experience latency and/or errors when logging into the Maxhire application.
System: Maxhire
Service: Login
Description: The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Aug 17, 2019 - 12:59 EDT