Bullhorn Talent Platform - E-Verify intermittent issues

Incident Report for Bullhorn

Resolved

The issue has been resolved. E-Verify functionality is completely functional.
Posted Sep 10, 2026 - 09:23 EDT

Investigating

We are aware of intermittent technical difficulties with E-Verify that may be impacting Talent Platform. Users may encounter errors when submitting or initiating E-Verify cases. Please try again later and contact Support if the issue persists. We will continue to monitor and provide updates as available.
Posted Sep 10, 2026 - 08:53 EDT
This incident affected: Bullhorn Talent Platform (Talent Platform - US Prod).