Internal support platform Outage

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 10:48 EDT

Identified

We are experiencing an unexpected outage with our 3rd party case tracking system, which is temporarily impacting our ability to service customer cases, live chats, and phone calls as normal.
Our technical teams are actively investigating the issue with the vendor and working to restore full functionality as quickly as possible.
Posted Sep 16, 2026 - 08:12 EDT