Bullhorn Back Office - Report Performance Issues

Incident Report for Bullhorn

Update

Users should be able to run new reports, reports that are stuck are processing slowly.
Posted Sep 16, 2026 - 15:08 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 16, 2026 - 15:02 EDT

Investigating


Impact: Some users may experience report performance issues.
System: Bullhorn Back Office
Cluster(s): BBO East
Service: All
Description: The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Sep 16, 2026 - 14:33 EDT
This incident affects: Bullhorn Back Office (BBO GRR).