Bullhorn ATS/CRM - Email Deliverability

Incident Report for Bullhorn

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 09:04 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2025 - 04:57 EDT

Identified

The issue has been identified. We are working towards a resolution with our vendor.
Posted Sep 24, 2025 - 13:20 EDT

Investigating


Impact: Some users may experience issues with email deliverability within the Bullhorn application.
System: Bullhorn ATS/CRM
Cluster(s): All
Service: Email
Description: The Bullhorn Technical Operations team is investigating this issue, further updates will be posted here when available.
Posted Sep 24, 2025 - 09:04 EDT